解决php插件安装后无法使用

2018-05-26T08:56:30

发现Atom自带的代码补全不太全,于是下载了autocomplete-php这款插件(会显示可选的参数,但不支持模糊搜索),下载完真正使用的使用会报错

找了很久,终于发现问题的所在,原来是没有配置环境变量。

首先打开php的配置文件——php.ini

找到下面这行,我的在722行,并将前面的分号去掉

;On windows:
;extension_dir = "ext"

接下来配置环境变量

1.右键此地电脑,左键属性

2.选择高级系统设置,选择环境变量

3.在系统变量中Path变量中,添加2个变量(php的安装路径)

D:\huanjing\wamp64\bin\php\php7.0.23

D:\huanjing\wamp64\bin\php\php7.0.23\ext

上面是我的,可能会和你们的不太一样,如果忘记了安装位置的话可以打开php.ini在刚刚删除分号的后面一行有安装路径,复制过来就可以。

点击确定,完成!

接下来我们来看一下,php的版本和扩展

win+R打开,输入cmd,回车

输入php -v

输入php -m

结束。。。

当前页面是本站的「Baidu MIP」版。发表评论请点击:完整版 »
因本文不是用Markdown格式的编辑器书写的,转换的页面可能不符合MIP标准。